Post

2 followers Follow
0
Avatar

GUI and simulator/HW screens not match/offset

Hi,

I am having an issue with the GUI screen not matching the HW and simulator screen. The simulator's screen matches exactly my LCD screen. It looks like the GUI's screen is offset to the left and it effects both the simulator and my LCD. 

I am using the STM32F429 Discovery project and modified it to use my own LCD (320x480 size) attached to the Discovery board but I can't figure out why am I getting such a result. Greatly appreciate your advice. 

 

Thanks,

Winston

Winston

Please sign in to leave a comment.

4 comments

0
Avatar

Hi Winston.

I believe this is due to minor text rendering differences between the Designer and the actual TouchGFX application.

Within the Designer we use Windows font rendering (The Designer is built using C# and WPF) whereas the TouchGFX application uses FreeType behind the scenes.

We will fix this issue in a coming version of the Designer.

Can you verify that the problem is related to text - use a few boxes and/or images on top of your background?

Hope this helps.

Martin Stig Stissing 0 votes
Comment actions Permalink
0
Avatar

Hi Martin,

Thanks for your reply. Yes, you are right. The offset only affects the text; everything else is okay. Is there any workaround that I can implement first? 

 

Thanks in advance,

Winston

Winston 0 votes
Comment actions Permalink
1
Avatar

Hi Winston.

Deselect the Auto-size property of your text area. This implies that the text area is positioned and sized as you desire in your TouchGFX application.

Hope this helps.

Martin Stig Stissing 1 vote
Comment actions Permalink